Making technology work for you...

Get Your Free Subscription By Email:

Baseband Hack

How to downgrade hacked Apple iPhone 3G/3GS from iPad baseband version 06.15.00

If you have your iPhone 3G/3GS flashed to iPad baseband 06.15.00 to retain the ultrasn0w unlock, and now somehow managed to make your phone unbootable here is the solution.

While trying to resurrect an Apple iPhone 3G stuck in a reboot loop at boot logo, I found that the only solution is to go for an factory unlock service and restore to the original iPhone iOS firmware with current modem version. Apple needs the correct baseband/modem version to enable the legal factory unlock via iTunes, and if you have the iPad baseband 06.15.00 it wont work. Here is a tutorial on how to downgrade the iPad baseband 06.15.00 to the correct one on Apple iPhone 3G.

Fixed modem

How to restore iOS 5.1.1 custom IPSW using iTunes without errors

Users relying on software carrier unlock ultrasn0w must use sn0wbreeze created custom IPSW firmware to upgrade there iDevice to an upgraded iOS version without updating the baseband which breaks the unlock. However, Apple iTunes prevents users from upgrading or restoring to these custom IPSW files and errors out the process with codes 3194 and 1600 - for which we have shared solution earlier. Here is an step-by-step guide to restore an custom IPSW file to iPhone using iTunes the correct way without any errors.

iOS 5.1.1

How To Jailbreak And Unlock An iPhone 3G Stuck At Modem 05.14.02 Running iOS Firmware 4.1

If you are one of the unlucky few who rely on an carrier-unlock for iPhone 3G and accidentally updated to iOS 4.1 upgrading your baseband (modem) to v 05.14.02 which is not unlockable, here is a method to let you upgrade your baseband to one of iPad 06.15.00 which is fortunately still vulnerable and will allow us to unlock using ultrasn0w.

In this comprehensive step-by-step illustrated guide we will walk-trough the complete process of jail-breaking and unlocking an iPhone 3G running iOS 4.1 having modem version 05.14.02.

iPhone 3G With iOS 4.1

Ultrasn0w Carrier Unlock Updated To Work With Baseband Later Than 05.13.04

The most widely used iOS software unlock Ultrasn0w just got updated by parent iPhone Dev Team to support carrier-unlocking on any baseband later than 05.13.04 for iPhone3G/3GS owners. This unlock is interestingly using the exploited AT+XAPP command security-hole which was actually plugged-in by Apple but it turned out that the very first iPad firmware 3.2.2 has baseband version 06.15.00 which is still vulnerable to AT+XAPP exploit and since the iPad baseband is built for the exact same baseband-chip as the iPhone3G/3GS what we have is an exploit with a carrier unlock for these devices. In simpler terms iPhone 3G/3Gs owners can unlock their devices running iOS 4.1/4.2 but there are some risks as posted next.

Apple iPhone 4 And iOS4 Confirmed Unlockable By iPhone Dev Team Member !

After getting success in jailbreaking iOS 4 there is another interesting development from iPhone Dev Team member musclenerd, few hours ago he tweeted confirming the upcoming final version of iOS 4 as unlockable even on the newer Baseband v 05.13.04, also pointing out

iPhone Dev Team To Release 3G Software Unlock On New Year’s Eve

iPhone UnlockIf you are stuck with an unlocked iPhone 3G waiting for a software unlock from iPhone Dev Team, here is some good news for you, the iPhone Dev Team has announced that an software based unlock application similar to QuickPwn for iPhone 3G will get released on New Year’s Eve, however only users having iPhone 3G's with 2.11.07 or earlier baseband will able to get the unlocker working, the unlock r

This is just one of the many helpful tips we have posted, You can find more stories here,
Do subscribe to updates using your favorite RSS feed reader or using the secure FeedBurner email update form on top of this post.